Duplicate Study Invitation Emails
Resolved
Jan 09 at 12:50pm PST
A fix has been deployed and email notifications are operating normally. We sincerely apologize for any confusion caused. No action is required from affected users — duplicate emails can be safely ignored or deleted.
Affected services
Updated
Jan 09 at 07:05am PST
Our team identified the root cause and immediately paused study invitation emails to prevent further duplicates while we implemented a fix.
Affected services
Created
Jan 08 at 06:08am PST
Some users began receiving duplicate email notifications for study invitations. Users invited to participate in research studies during this period may have received multiple copies of the same invitation.
Affected services